$re = '/(^(?=[^,]*?\bran\b)(?=[^,]*?\bfast\b)[^,]*)/m';
$str = 'Jim ran fast, but did win the race
Jim ran well, but John ran fast too.
Jim ran well, John ran fast, and Jane ran fast.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);