re = /(^(?=[^,]*?\bran\b)(?=[^,]*?\bfast\b)[^,]*)/m
str = 'Jim ran fast, but did win the race
Jim ran well, but John ran fast too.
Jim ran well, John ran fast, and Jane ran fast.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end