package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[2-9,],\d\d\d$`)
var str = `2,222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}