$re = '/^[2-9,],\d\d\d$/m';
$str = '2,222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);