$re = '/^(?! )(?!.* )(?!.* $)[^\s].*$/m';
$str = 'words with single spaces
space at beginning
space at the end
words with multiple spaces';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);