re = /^(?! )(?!.* )(?!.* $)[^\s].*$/m
str = 'words with single spaces
space at beginning
space at the end
words with multiple spaces'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end