#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm).*(^.*ABC.*XYZ.*?[\r\n]{1}).*"
Local $sString = "JUNKTEXTJUNKTEXTJUNKTEXT" & @CRLF & _
"JUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXT" & @CRLF & _
"NOTJUNK ABC NOTJUNK" & @CRLF & _
"DEF GHI JKL" & @CRLF & _
"MNO PQR STW" & @CRLF & _
"UVW XYZ NOTJUNK" & @CRLF & _
"JUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXT" & @CRLF & _
"JUNKTEXTJUNKTEXT" & @CRLF & _
"JUNKTEXTJUNKTEXT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")