import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(^.*ABC.*XYZ.*?[\\r\\n]{1}).*";
final String string = "JUNKTEXTJUNKTEXTJUNKTEXT\n"
+ "JUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXT\n"
+ "NOTJUNK ABC NOTJUNK\n"
+ "DEF GHI JKL\n"
+ "MNO PQR STW\n"
+ "UVW XYZ NOTJUNK\n"
+ "JUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXTJUNKTEXT\n"
+ "JUNKTEXTJUNKTEXT\n"
+ "JUNKTEXTJUNKTEXT";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}