#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z]|[A-Z]).*\1$"
Local $sString = "xyyyxyx" & @CRLF & _
"yxyxyxy" & @CRLF & _
"zxyxyxz" & @CRLF & _
"xyxyxyy" & @CRLF & _
"" & @CRLF & _
"xgjyhdtfx" & @CRLF & _
"yjsaudgty" & @CRLF & _
"xuhgrey" & @CRLF & _
"yudgfsx" & @CRLF & _
"yaaay"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")