$re = '/^\w.+(?=\r?\n\d)/m';
$str = 'More text here
Vice President of Compliance
10004 South 152nd St. #A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);