re = /^\w.+(?=\r?\n\d)/m
str = 'More text here
Vice President of Compliance
10004 South 152nd St. #A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end