#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=<br><b>).+?(?=<br>)"
Local $sString = " </table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#257fba">" & @CRLF & _
" <td height="17" colspan="5" valign="top" align="right"><font color="#FFFFFF">Dienstag Sonnenscheindauer:</font></td>" & @CRLF & _
" <td height="17" colspan="1" valign="bottom" align="center"><font color="#FFFFFF">6-7 Stunden</font></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#257fba">" & @CRLF & _
" <td height="17" colspan="5" valign="top" align="right"><font color="#FFFFFF">Niederschlags-Wahrscheinlichkeit: </font></td>" & @CRLF & _
" <td height="17" colspan="1" valign="bottom" align="center"><font color="#FFFFFF">52 %</font></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="6" align="left">" & @CRLF & _
" <br><b>Das Wetter in Reutlingen am Dienstag, 28.3.2017:</b> Am Vormittag wechselnd bewölkt bei 15 Grad, nachmittags sind neben Wolkenlücken bei 18 Grad auch Schauer möglich. Die Nacht verläuft wechselnd bewölkt bei Werten um 6 Grad.<br><br>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr> " & @CRLF & _
" <td colspan="4" align="right">" & @CRLF & _
" <center>" & @CRLF & _
" <button type="button" class="btn btn-default"><span class="glyphicon glyphicon-arrow-left"></span> Tag</button> <a href="/wetter/morgen/reutlingen/DE23046.html"><button type="button" class="btn btn-primary">Tag <span class="glyphicon glyphicon-arrow-right"></span></button></a>" & @CRLF & _
" </center>" & @CRLF & _
" </td>" & @CRLF & _
" <td colspan="2" align="right">" & @CRLF & _
" <table border="0" cellpadding="0" cellspacing="0">" & @CRLF & _
" <tr> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")