use strict;
my $str = ' </table>
</td>
</tr>
<tr bgcolor="#257fba">
<td height="17" colspan="5" valign="top" align="right"><font color="#FFFFFF">Dienstag Sonnenscheindauer:</font></td>
<td height="17" colspan="1" valign="bottom" align="center"><font color="#FFFFFF">6-7 Stunden</font></td>
</tr>
<tr bgcolor="#257fba">
<td height="17" colspan="5" valign="top" align="right"><font color="#FFFFFF">Niederschlags-Wahrscheinlichkeit: </font></td>
<td height="17" colspan="1" valign="bottom" align="center"><font color="#FFFFFF">52 %</font></td>
</tr>
<tr>
<td colspan="6" align="left">
<br><b>Das Wetter in Reutlingen am Dienstag, 28.3.2017:</b> Am Vormittag wechselnd bewölkt bei 15 Grad, nachmittags sind neben Wolkenlücken bei 18 Grad auch Schauer möglich. Die Nacht verläuft wechselnd bewölkt bei Werten um 6 Grad.<br><br>
</td>
</tr>
<tr>
<td colspan="4" align="right">
<center>
<button type="button" class="btn btn-default"><span class="glyphicon glyphicon-arrow-left"></span> Tag</button> <a href="/wetter/morgen/reutlingen/DE23046.html"><button type="button" class="btn btn-primary">Tag <span class="glyphicon glyphicon-arrow-right"></span></button></a>
</center>
</td>
<td colspan="2" align="right">
<table border="0" cellpadding="0" cellspacing="0">
<tr> ';
my $regex = qr/(?s)(?<=<br><b>).+?(?=<br>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}