#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[её]л(?:оч)?ка$"
Local $sString = "Елка" & @CRLF & _
"елка" & @CRLF & _
"ель" & @CRLF & _
"елочка" & @CRLF & _
"Ёлка" & @CRLF & _
"йолко" & @CRLF & _
"ёлка" & @CRLF & _
"ёлочка" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")