$re = '/^[её]л(?:оч)?ка$/im';
$str = 'Елка
елка
ель
елочка
Ёлка
йолко
ёлка
ёлочка
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);