package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[1-9]|1[0-2]?\b`)
var str = `11
12
13
1
0
92`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}