$re = '/\b[1-9]|1[0-2]?\b/m';
$str = '11
12
13
1
0
92';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);