#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?\d+(?:\.\d+)?"
Local $sString = "100" & @CRLF & _
"001" & @CRLF & _
"1.00" & @CRLF & _
"1." & @CRLF & _
"2." & @CRLF & _
"some number here 2.00." & @CRLF & _
"$20" & @CRLF & _
"200%" & @CRLF & _
"0.5%" & @CRLF & _
"-5%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")