package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?\d+(?:\.\d+)?`)
var str = `100
001
1.00
1.
2.
some number here 2.00.
$20
200%
0.5%
-5%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}