#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^TEXT\h([A-Z0-9]{14})"
Local $sString = "Material B7E671143D244B" & @CRLF & _
"====================================" & @CRLF & _
"TEXT 2F3139D816C34D 1" & @CRLF & _
"TEXT B6A968EF2505A2 1" & @CRLF & _
"TEXT 35206697A04F91 1" & @CRLF & _
"TEXT EB485AF490D83D 1" & @CRLF & _
"TEXT 0DAB42294BD9B3 1" & @CRLF & _
"TEXT 3D6525BEE360E1 0" & @CRLF & _
"" & @CRLF & _
"Material D6906B886B06E3" & @CRLF & _
"====================================" & @CRLF & _
"TEXT 0CCECCCCFB62AE 1" & @CRLF & _
"TEXT 1E14CB29AB43F0 1" & @CRLF & _
"TEXT FB7F0DCE9B5950 1" & @CRLF & _
"" & @CRLF & _
"Material 431831490FD5C9" & @CRLF & _
"====================================" & @CRLF & _
"TEXT 9D77B6474696D8 1" & @CRLF & _
"TEXT D04DEE5DF130A4 1" & @CRLF & _
"TEXT B6A968EF2505A2 1" & @CRLF & _
"TEXT 8C37245A4F0F81 1" & @CRLF & _
"TEXT A39FAFFC5ABC06 1" & @CRLF & _
"TEXT D24199644F2EE6 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")