import re
regex = re.compile(r"^TEXT\h([A-Z0-9]{14})", flags=re.MULTILINE)
test_str = ("Material B7E671143D244B\n"
"====================================\n"
"TEXT 2F3139D816C34D 1\n"
"TEXT B6A968EF2505A2 1\n"
"TEXT 35206697A04F91 1\n"
"TEXT EB485AF490D83D 1\n"
"TEXT 0DAB42294BD9B3 1\n"
"TEXT 3D6525BEE360E1 0\n\n"
"Material D6906B886B06E3\n"
"====================================\n"
"TEXT 0CCECCCCFB62AE 1\n"
"TEXT 1E14CB29AB43F0 1\n"
"TEXT FB7F0DCE9B5950 1\n\n"
"Material 431831490FD5C9\n"
"====================================\n"
"TEXT 9D77B6474696D8 1\n"
"TEXT D04DEE5DF130A4 1\n"
"TEXT B6A968EF2505A2 1\n"
"TEXT 8C37245A4F0F81 1\n"
"TEXT A39FAFFC5ABC06 1\n"
"TEXT D24199644F2EE6 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")