use strict;
my $str = 'AND (Util.Source=\'IP%\' AND Util.ReqType = \'IP\') AND (Util.Epinum is null) AND ([Episode].[YN] = \'Y\')
AND (Util.Source=\'IP%\' AND Util.ReqType = \'IP\') AND (Util.Epinum is null) AND ([Episode].[YN] = \'Y\') AND (Episode.Paste = \'Y\') AND [Episode].[Source] = \'%6\' AND [Episode].[TFC] NOT IN (\'LWC\', \'POD\')';
my $regex = qr/AND\s+\(*\[*Episode\]*\.\[*\w+\]*\s*(<>|[><]?=|(?:NOT\s+)?IN)(\s*\'*(\((.*?)\)+|NULL|\S+)\'*\s*\)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}