re = /AND\s+\(*\[*Episode\]*\.\[*\w+\]*\s*(<>|[><]?=|(?:NOT\s+)?IN)(\s*\'*(\((.*?)\)+|NULL|\S+)\'*\s*\)*)/m
str = 'AND (Util.Source=\'IP%\' AND Util.ReqType = \'IP\') AND (Util.Epinum is null) AND ([Episode].[YN] = \'Y\')
AND (Util.Source=\'IP%\' AND Util.ReqType = \'IP\') AND (Util.Epinum is null) AND ([Episode].[YN] = \'Y\') AND (Episode.Paste = \'Y\') AND [Episode].[Source] = \'%6\' AND [Episode].[TFC] NOT IN (\'LWC\', \'POD\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end