#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S*f\S*aef"
Local $sString = "RegExr was created by gskinner.com, and is proudly hosted by Media Temple." & @CRLF & _
"aeqfdfaefaef " & @CRLF & _
"" & @CRLF & _
"Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode." & @CRLF & _
"" & @CRLF & _
"The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns." & @CRLF & _
"" & @CRLF & _
"Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")