package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*f\S*aef`)
var str = `RegExr was created by gskinner.com, and is proudly hosted by Media Temple.
aeqfdfaefaef
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns.
Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}