package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)\s+(\S+)\s+\((.*)\)$`)
var str = `Foo Bar-8.io 5.61.0-rc-1 (data)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}