# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*referrer: ")([^\?]+\?)\?([^"]+)(")/$1$2$4/gm;t' <<< "2024/11/15 13:10:11 [error] 4080#4080: *260309 connect() failed (111: Connection refused) while connecting to upstream, client: 210.54.88.72, server: mpos.mintpayments.com, request: \"GET /payment-mint/cnpPayments/v1/publicKeys\", upstream: \"https://10.20.3.59:28076//cnpPayments/v1/publicKeys?callback=jQuery360014295356911736334_17313690733...\", host: \"test.mintpayments.com\", referrer: \"https://vicky9.mintpayments.com/testing??asd\""