using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*referrer: "")([^\?]+\?)\?([^""]+)("")";
string substitution = @"$1$2$4";
string input = @"2024/11/15 13:10:11 [error] 4080#4080: *260309 connect() failed (111: Connection refused) while connecting to upstream, client: 210.54.88.72, server: mpos.mintpayments.com, request: ""GET /payment-mint/cnpPayments/v1/publicKeys"", upstream: ""https://10.20.3.59:28076//cnpPayments/v1/publicKeys?callback=jQuery360014295356911736334_17313690733..."", host: ""test.mintpayments.com"", referrer: ""https://vicky9.mintpayments.com/testing??asd""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}