import Foundation
let pattern = #"^[0-9\+\-\s]{1,12}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"4686787787+354645666666666666884"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}