$re = '/(?:\[|\G(?!^)]\h\[?)\K[^][\s]+/m';
$str = '[one] [two] [three] 1234567893430ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);