re = /(?:\[|\G(?!^)]\h\[?)\K[^][\s]+/m
str = '[one] [two] [three] 1234567893430ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end