$re = '/[a-zа-я][A-ZА-Я]/m';
$str = 'ПравдаНет
pravdaNet
правданет
pravdanet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);