using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"e+(?<=\w{4})\b";
string input = @"abcdeeee
more
wheeeheeeee
pie
me
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}