$re = '/e+(?<=\w{4})\b/';
$str = 'abcdeeee
more
wheeeheeeee
pie
me
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);