import re
regex = re.compile(r"^(?:[1-9]\d*?|0)?(?:\.(?:\d*?[1-9]|0))?(?<=[\d])$", flags=re.MULTILINE)
test_str = ("1.6\n"
".16\n"
"16\n"
"0.6\n"
"01.6\n"
"0.\n"
"0\n"
"0.0\n"
".0\n"
".01\n"
".001\n"
"1.60\n"
"100\n"
"100.0001\n"
"601.10\n"
"601.119201\n"
"1.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")