package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(\.pdf|\.html)$`)
var str = `https://www.beispiel.de/haus.html
https://www.beispiel.de/haus.pdf
https://www.beispiel.de/haus.htm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}