$re = '/.*?(\.pdf|\.html)$/m';
$str = 'https://www.beispiel.de/haus.html
https://www.beispiel.de/haus.pdf
https://www.beispiel.de/haus.htm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);