using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((jan|feb|mar|apr|may|jun|july|aug|sep|sept|oct|nov|dec|January|february|march|april|may|june|august|september|october|november|december|\d{1,2})[ -\/',]\d{2,4})\s+([-]|till|to)\s+(?:((jan|feb|mar|apr|may|jun|july|aug|sep|sept|oct|nov|dec|January|february|march|april|may|june|august|september|october|november|december|\d{1,2})[ -\/',]\d{2,4})|present|date|now)";
string input = @"dec 2017 - aug 2014
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}