package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((jan|feb|mar|apr|may|jun|july|aug|sep|sept|oct|nov|dec|January|february|march|april|may|june|august|september|october|november|december|\d{1,2})[ -\/',]\d{2,4})\s+([-]|till|to)\s+(?:((jan|feb|mar|apr|may|jun|july|aug|sep|sept|oct|nov|dec|January|february|march|april|may|june|august|september|october|november|december|\d{1,2})[ -\/',]\d{2,4})|present|date|now)`)
var str = `dec 2017 - aug 2014
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}