import re
regex = re.compile(r"^(?<code>\+?\d{1,3})[-\s]{0,}(?<number>\(?\d{3}\)?[-\s]{0,}\d{3}[-\s]{0,}\d{2}[-\s]{0,}\d{2})$", flags=re.MULTILINE)
test_str = ("+447700150563\n"
"+14247323156\n"
"+12048170348\n"
"+33644628265\n"
"+78005553535\n"
"88005553535\n"
"8-800-555-35-35\n"
"8 800 555 35 35\n"
"8(800)5553535\n"
"8-(800)5553535\n"
"8-(800) 555 3535\n"
"8 (800) 555 3535")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")