package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:\s|^)s(?:\s|$)`)
var str = `Men's
S
Just S Things
Somethings`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}