$re = '/(?:\s|^)s(?:\s|$)/i';
$str = 'Men\'s
S
Just S Things
Somethings';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);