$re = '/((?s)<product>.*?<\/product>)/m';
$str = '<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);