// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?s)<product>.*?<\/product>)").unwrap();
let string = "<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>instock</available>
</product>
<product><ean_barcode>...</ean_barcode>
<available>outofstock</available>
</product>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}