re = /([^=]*)\|/m
str = 'lineItem=USA~ACQ~AppNexus~PD~interscroller~D_M~lifestyle~ADF-10900-0221a|bannerDomain=marieclaire.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end