// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^=]*)\|").unwrap();
let string = "lineItem=USA~ACQ~AppNexus~PD~interscroller~D_M~lifestyle~ADF-10900-0221a|bannerDomain=marieclaire.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}