using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A(?=(?>^(?=(.(?>(?-1)|\n).)(?>\n|\Z)).*\n)++.*+\Z)";
string input = @"oooooooxooooxooooooo
ooxooooxooooxooooxoo
ooxooooooooooooooxoo
oooxooooooooooooxooo
ooooxxxxxxxxxxxxoooo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}