$re = '/\A(?=(?>^(?=(.(?>(?-1)|\n).)(?>\n|\Z)).*\n)++.*+\Z)/m';
$str = 'oooooooxooooxooooooo
ooxooooxooooxooooxoo
ooxooooooooooooooxoo
oooxooooooooooooxooo
ooooxxxxxxxxxxxxoooo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);